Live status
History

Elevated iDeal errors

Incident Report for Stripe

Resolved

Between 14:25 - 14:45 UTC there was a disruption with the iDEAL payment method causing increased error rates for iDEAL transactions. The issue was external to Stripe and is now resolved.
Posted Mar 25, 2026 - 14:59 UTC

Investigating

We're currently observing elevated errors on the iDEAL payment method that began at 14:25 UTC. This issue is external to Stripe. We are actively monitoring the situation and will provide updates as more information becomes available.
Posted Mar 25, 2026 - 14:44 UTC
This incident affected: Acquirers and payment methods.