Live status
History

Elevated MobilePay errors

Incident Report for Stripe

Resolved

Between 14:18–17:20 UTC May 16th, we saw elevated error rates and response times with MobilePay requests. This is now resolved.
Posted May 16, 2026 - 18:53 UTC

Update

Between 14:18–17:20 UTC May 16th, we saw elevated error rates and response times with MobilePay requests. This is now resolved.
Posted May 16, 2026 - 23:45 UTC

Investigating

We're currently investigating elevated MobilePay errors. We'll post an update soon.
Posted May 16, 2026 - 16:01 UTC
This incident affected: Acquirers and payment methods.