Live status
History

Elevated API errors and intermittent Dashboard loading errors

Incident Report for Stripe

Resolved

From 20:45–23:15 UTC, we saw elevated error rates and response times with the API. This is now resolved.
Posted Mar 13, 2025 - 00:36 UTC

Identified

We continue to observe elevated API error rates and elevated latency across some products. Troubleshooting continues to isolate the root cause of the issue. We will provide an update soon.
Posted Mar 12, 2025 - 22:26 UTC

Update

We continue to investigate an issue causing elevated error rates and response times with the API and intermittent loading errors with the Dashboard.

We will post an update as soon as possible.
Posted Mar 12, 2025 - 21:34 UTC

Investigating

Starting on March 12, 2025, at 20:45 UTC, we began investigating elevated error rates and response times with the API and intermittent loading errors with the Dashboards.
Posted Mar 12, 2025 - 21:19 UTC
This incident affected: Stripe API and Stripe core components.