Live status
History

Elevated iDEAL errors

Incident Report for Stripe

Resolved

Between 11:30 - 13:41 UTC there was a disruption with the iDEAL payment method causing increased error rates for iDEAL transactions. The issue was external to Stripe and is now resolved.
Posted Aug 20, 2025 - 14:05 UTC

Investigating

We're currently investigating a Partial Service disruption of the iDEAL payment method that began at 11:30 UTC. This issue is external to Stripe and is causing increased error rates for transactions processed through the iDEAL payment method. We are actively monitoring the situation and will provide updates as more information becomes available.
Posted Aug 20, 2025 - 11:57 UTC
This incident affected: Acquirers and payment methods.