Live status
History

Elevated Swish errors

Incident Report for Stripe

Resolved

From 11:14-11:43 UTC, Swish experienced a service disruption impacting a number of service providers.
The issue was external to Stripe and is now resolved.
Posted May 08, 2025 - 12:08 UTC

Investigating

We're currently investigating a service disruption impacting Swish, starting at 11:17 UTC.
The issue is external to Stripe, and we're actively monitoring the situation. We'll provide updates as soon as more information becomes available.
Posted May 08, 2025 - 11:36 UTC
This incident affected: Acquirers and payment methods.