Live status
History

Elevated errors on Google Pay payments

Incident Report for Stripe

Resolved

The issue with Google Pay has been resolved.
Posted Sep 16, 2026 - 17:52 UTC

Update

We've confirmed with the upstream partner that the Google Pay issue is recovering. We are monitoring and will provide an update when the issue is resolved.
Posted Sep 16, 2026 - 17:20 UTC

Monitoring

We're currently investigating elevated errors on Google Pay payments. We'll post an update soon.
Posted Sep 16, 2026 - 10:05 UTC
This incident affected: Stripe core components and Acquirers and payment methods.